首页 > PAT 1044 Shopping in Mars 未通过
头像
vivi21
编辑于 2020-07-02 09:35
+ 关注

PAT 1044 Shopping in Mars 未通过

大家好,我在做 PAT 1044 Shopping in Mars (25) 遇到点问题,测试用例2没有通过,找不出来问题,我用的二分法,希望大家帮我看看。

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤), the total number of diamonds on the chain, and M (≤), the amount that the customer has to pay. Then the next line contains N positive numbers D1DN (Di103 for all ,) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj > with (Di + ... + Dj −) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5


#include <iostream>
#include <vector>
using namespace std;

int helper(int sum[], int len, int i, int target) {
    int left = i, right = len;
    while (left <= right) {
        int mid = left + (right - left) / 2;
        if (sum[mid] - sum[i - 1] >= target)
            right = mid - 1;
        else
            left = mid + 1;
    }
    return left;
}

int main() {

    int n, m;
    vector<int> res;

    cin >> n >> m;
    int values[n + 1] = {0};

    for (int i = 1; i <= n; ++i) {
        cin >> values[i];
        values[i] += values[i - 1];
    }
    int min_ans = 999999;
    for(int i = 1; i <= n; ++i) {
        int j = helper(values, n, i, m);
        if (j <= n) {
            int temp = values[j] - values[i - 1];
            if (temp > min_ans) continue;
            if (temp < min_ans) {
                res.clear();
                min_ans = temp;
            }
            res.push_back(i);
            res.push_back(j);
        }
    }
    for (int i = 0; i < res.size(); i += 2) 
        printf("%d-%d\n", res[i], res[i + 1]);
        
    return 0;
}

全部评论

(0) 回帖
加载中...
话题 回帖

推荐话题

相关热帖

近期热帖

近期精华帖

热门推荐